aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-04-01 22:05:53 +0200
committerMax Kellermann <max@duempel.org>2009-04-01 22:05:53 +0200
commitb9a5e787807e85898e9b9d13d41e0a1f0230c359 (patch)
tree7a4b95721d5b6f5bf2c4e13ff5e07afb46f4333a /configure.ac
parent0a62bdadedd71e40cc5d49366b04d883b9a4f3b3 (diff)
downloadmpd-b9a5e787807e85898e9b9d13d41e0a1f0230c359.tar.gz
mpd-b9a5e787807e85898e9b9d13d41e0a1f0230c359.tar.xz
mpd-b9a5e787807e85898e9b9d13d41e0a1f0230c359.zip
Makefile.am: use LAME_CFLAGS and LAME_LIBS
Don't append LAME_CFLAGS/LAME_LIBS to MPD_CFLAGS/MPD_LIBS in configure.ac. Export them via AC_SUBST() instead.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 45ce77cdf..b6a687664 100644
--- a/configure.ac
+++ b/configure.ac
@@ -957,12 +957,14 @@ MPD_AUTO_PKG(oggvorbis_encoder, VORBISENC, [vorbisenc],
[Ogg Vorbis encoder], [libvorbisenc not found])
if test x$enable_lame = xyes; then
- AM_PATH_LAME([MPD_LIBS="$MPD_LIBS $LAME_LIBS"
- MPD_CFLAGS="$MPD_CFLAGS $LAME_CFLAGS"],
+ AM_PATH_LAME(,
[enable_lame=no;
AC_MSG_WARN(You need lame -- disabling lame support)])
fi
+AC_SUBST(LAME_CFLAGS)
+AC_SUBST(LAME_LIBS)
+
if test x$enable_oggvorbis_encoder != xno || test x$enable_lame != xno; then
# at least one encoder plugin is enabled
enable_encoder=yes