aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 45ce77cdf..b6a687664 100644
--- a/configure.ac
+++ b/configure.ac
@@ -957,12 +957,14 @@ MPD_AUTO_PKG(oggvorbis_encoder, VORBISENC, [vorbisenc],
[Ogg Vorbis encoder], [libvorbisenc not found])
if test x$enable_lame = xyes; then
- AM_PATH_LAME([MPD_LIBS="$MPD_LIBS $LAME_LIBS"
- MPD_CFLAGS="$MPD_CFLAGS $LAME_CFLAGS"],
+ AM_PATH_LAME(,
[enable_lame=no;
AC_MSG_WARN(You need lame -- disabling lame support)])
fi
+AC_SUBST(LAME_CFLAGS)
+AC_SUBST(LAME_LIBS)
+
if test x$enable_oggvorbis_encoder != xno || test x$enable_lame != xno; then
# at least one encoder plugin is enabled
enable_encoder=yes