aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-04-01 22:05:07 +0200
committerMax Kellermann <max@duempel.org>2009-04-01 22:05:07 +0200
commit0a62bdadedd71e40cc5d49366b04d883b9a4f3b3 (patch)
tree567d6d9737a8a4723815ecb9c2104bfa5e952343 /configure.ac
parent9509bd460fb0abd7100fc1ebb6c508110ff2dcb0 (diff)
downloadmpd-0a62bdadedd71e40cc5d49366b04d883b9a4f3b3.tar.gz
mpd-0a62bdadedd71e40cc5d49366b04d883b9a4f3b3.tar.xz
mpd-0a62bdadedd71e40cc5d49366b04d883b9a4f3b3.zip
configure.ac: fail when vorbis encoder is enabled but not found
Use MPD_AUTO_PKG(). Removed the checks for the Ogg Vorbis decoder plugin, this is not directly related.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 5 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index e7f3f5865..45ce77cdf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -516,9 +516,9 @@ dnl encoder plugins
dnl
AC_ARG_ENABLE(oggvorbis-encoder,
- AS_HELP_STRING([--disable-oggvorbis-encoder],
- [disable support for ogg streaming (default: enable)]),,
- [enable_oggvorbis_encoder=yes])
+ AS_HELP_STRING([--enable-oggvorbis-encoder],
+ [enable support for ogg streaming]),,
+ [enable_oggvorbis_encoder=auto])
AC_ARG_ENABLE(lame,
AS_HELP_STRING([--disable-lame],
@@ -953,20 +953,8 @@ else
enable_lame=no
fi
-if test x$enable_oggvorbis_encoder = xyes; then
- if test x$enable_oggvorbis = xno; then
- AC_MSG_WARN([disabling ogg shout streaming support because vorbis is not enabled])
- enable_oggvorbis_encoder=no
- fi
- if test x$use_tremor = xyes; then
- AC_MSG_WARN([disabling ogg shout streaming support because tremor does not support vorbis encoding])
- enable_oggvorbis_encoder=no
- fi
- if test x$enable_oggvorbis_encoder = xyes; then
- PKG_CHECK_MODULES(VORBISENC, [vorbisenc],,
- enable_oggvorbis_encoder=no)
- fi
-fi
+MPD_AUTO_PKG(oggvorbis_encoder, VORBISENC, [vorbisenc],
+ [Ogg Vorbis encoder], [libvorbisenc not found])
if test x$enable_lame = xyes; then
AM_PATH_LAME([MPD_LIBS="$MPD_LIBS $LAME_LIBS"