aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authork-m_schindler <k-m_schindler@b956fd51-792f-4845-bead-9b4dfca2ff2c>2013-01-27 22:39:36 +0000
committerk-m_schindler <k-m_schindler@b956fd51-792f-4845-bead-9b4dfca2ff2c>2013-01-27 22:39:36 +0000
commit045356f498df75c1d87a56512d655e6fc9f77558 (patch)
treee58651b0a8344308b47c8e458f5f9185cf824046 /configure.ac
parentdf5f74a4a859a661893cb55488454844e0b03d85 (diff)
downloadusdx-045356f498df75c1d87a56512d655e6fc9f77558.tar.gz
usdx-045356f498df75c1d87a56512d655e6fc9f77558.tar.xz
usdx-045356f498df75c1d87a56512d655e6fc9f77558.zip
add version detection for lua in configure
git-svn-id: svn://svn.code.sf.net/p/ultrastardx/svn/trunk@2935 b956fd51-792f-4845-bead-9b4dfca2ff2c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 3c7f1d62..c0cebb94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -179,13 +179,18 @@ PKG_HAVE([sqlite3], [sqlite3], yes)
# Mac OS X and other linux distributions use lua.pc
PKG_HAVE([lua], [lua5.2], no)
lua_LIB_NAME="lua5.2"
-if [[ x$lua_HAVE = xno ]]; then
+if [[ x$lua_HAVE = xyes ]]; then
+ PKG_VERSION([lua], [lua5.2])
+else
PKG_HAVE([lua], [lua5.1], no)
lua_LIB_NAME="lua5.1"
- if [[ x$lua_HAVE = xno ]]; then
- PKG_HAVE([lua], [lua >= 5.1], yes)
+ if [[ x$lua_HAVE = xyes ]]; then
+ PKG_VERSION([lua], [lua5.1])
+ else
+ PKG_HAVE([lua], [lua >= 5.1], yes)
lua_LIB_NAME="lua"
- fi
+ PKG_VERSION([lua], [lua])
+ fi
fi
AC_SUBST(lua_LIB_NAME)