aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authork-m_schindler <k-m_schindler@b956fd51-792f-4845-bead-9b4dfca2ff2c>2013-01-27 21:55:27 +0000
committerk-m_schindler <k-m_schindler@b956fd51-792f-4845-bead-9b4dfca2ff2c>2013-01-27 21:55:27 +0000
commitdf5f74a4a859a661893cb55488454844e0b03d85 (patch)
tree3b2590aef3b1f06b147d35bd9f5f86a96a80fb60 /configure.ac
parentf38f69db819e7eb45d6e112c8ee265a2eaf31878 (diff)
downloadusdx-df5f74a4a859a661893cb55488454844e0b03d85.tar.gz
usdx-df5f74a4a859a661893cb55488454844e0b03d85.tar.xz
usdx-df5f74a4a859a661893cb55488454844e0b03d85.zip
add configure check for lua 5.2 on ubuntu
git-svn-id: svn://svn.code.sf.net/p/ultrastardx/svn/trunk@2934 b956fd51-792f-4845-bead-9b4dfca2ff2c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 11 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index e8d60626..3c7f1d62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -174,14 +174,18 @@ PKG_HAVE([freetype], [freetype2], yes)
# find sqlite3
PKG_HAVE([sqlite3], [sqlite3], yes)
-# find lua 5.1
-# (K)Ubuntu uses lua5.1.pc, Mac OS X and other
-# linux distributions use lua.pc
-PKG_HAVE([lua], [lua5.1], no)
-lua_LIB_NAME="lua5.1"
+# find lua 5.2 or 5.11
+# (K)Ubuntu uses lua5.2.pc and lua5.1.pc,
+# Mac OS X and other linux distributions use lua.pc
+PKG_HAVE([lua], [lua5.2], no)
+lua_LIB_NAME="lua5.2"
if [[ x$lua_HAVE = xno ]]; then
- PKG_HAVE([lua], [lua >= 5.1], yes)
- lua_LIB_NAME="lua"
+ PKG_HAVE([lua], [lua5.1], no)
+ lua_LIB_NAME="lua5.1"
+ if [[ x$lua_HAVE = xno ]]; then
+ PKG_HAVE([lua], [lua >= 5.1], yes)
+ lua_LIB_NAME="lua"
+ fi
fi
AC_SUBST(lua_LIB_NAME)