aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 3c7f1d62..c0cebb94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -179,13 +179,18 @@ PKG_HAVE([sqlite3], [sqlite3], yes)
# Mac OS X and other linux distributions use lua.pc
PKG_HAVE([lua], [lua5.2], no)
lua_LIB_NAME="lua5.2"
-if [[ x$lua_HAVE = xno ]]; then
+if [[ x$lua_HAVE = xyes ]]; then
+ PKG_VERSION([lua], [lua5.2])
+else
PKG_HAVE([lua], [lua5.1], no)
lua_LIB_NAME="lua5.1"
- if [[ x$lua_HAVE = xno ]]; then
- PKG_HAVE([lua], [lua >= 5.1], yes)
+ if [[ x$lua_HAVE = xyes ]]; then
+ PKG_VERSION([lua], [lua5.1])
+ else
+ PKG_HAVE([lua], [lua >= 5.1], yes)
lua_LIB_NAME="lua"
- fi
+ PKG_VERSION([lua], [lua])
+ fi
fi
AC_SUBST(lua_LIB_NAME)