aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 04:00:03 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:35:31 -0700
commit52fc168905b2ce3692408d7a80440048258f3aed (patch)
tree9fa140d6b291fcf5f95e4630792332d97d48c87c /configure.ac
parent3bb03db09714eb0eac37cc967396e5cc62b823f3 (diff)
downloadmpd-52fc168905b2ce3692408d7a80440048258f3aed.tar.gz
mpd-52fc168905b2ce3692408d7a80440048258f3aed.tar.xz
mpd-52fc168905b2ce3692408d7a80440048258f3aed.zip
configure.ac: Add Post Decoder Plugins Tests header
Add Post Decoder Plugins Tests and move things that shouldn't be in individual tests to it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 384882552..8b17c36af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1097,9 +1097,6 @@ fi
AM_CONDITIONAL(HAVE_OGGFLAC, test x$enable_oggflac = xyes)
-AM_CONDITIONAL(HAVE_FLAC_COMMON,
- test x$enable_flac = xyes || test x$enable_oggflac = xyes)
-
dnl -------------------------------- Ogg Vorbis -------------------------------
if test x$enable_tremor != xyes -a test x$enable_vorbis = xyes; then
PKG_CHECK_MODULES(VORBIS, [ogg vorbis vorbisfile],
@@ -1109,9 +1106,6 @@ fi
AM_CONDITIONAL(ENABLE_VORBIS_DECODER, test x$enable_vorbis = xyes)
-AM_CONDITIONAL(HAVE_OGG_COMMON,
- test x$enable_vorbis = xyes || test x$enable_oggflac = xyes || test x$enable_flac = xyes)
-
dnl --------------------------------- sidplay ---------------------------------
found_sidplay=$HAVE_CXX
MPD_AUTO_PRE(sidplay, [sidplay decoder plugin], [No C++ compiler found])
@@ -1176,6 +1170,14 @@ fi
AM_CONDITIONAL(ENABLE_WILDMIDI, test x$enable_wildmidi = xyes)
+dnl ------------------------ Post Decoder Plugins Tests -----------------------
+
+AM_CONDITIONAL(HAVE_OGG_COMMON,
+ test x$enable_vorbis = xyes || test x$enable_oggflac = xyes || test x$enable_flac = xyes)
+
+AM_CONDITIONAL(HAVE_FLAC_COMMON,
+ test x$enable_flac = xyes || test x$enable_oggflac = xyes)
+
dnl
dnl Encoder API and shout/httpd output plugin
dnl