aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 384882552..8b17c36af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1097,9 +1097,6 @@ fi
AM_CONDITIONAL(HAVE_OGGFLAC, test x$enable_oggflac = xyes)
-AM_CONDITIONAL(HAVE_FLAC_COMMON,
- test x$enable_flac = xyes || test x$enable_oggflac = xyes)
-
dnl -------------------------------- Ogg Vorbis -------------------------------
if test x$enable_tremor != xyes -a test x$enable_vorbis = xyes; then
PKG_CHECK_MODULES(VORBIS, [ogg vorbis vorbisfile],
@@ -1109,9 +1106,6 @@ fi
AM_CONDITIONAL(ENABLE_VORBIS_DECODER, test x$enable_vorbis = xyes)
-AM_CONDITIONAL(HAVE_OGG_COMMON,
- test x$enable_vorbis = xyes || test x$enable_oggflac = xyes || test x$enable_flac = xyes)
-
dnl --------------------------------- sidplay ---------------------------------
found_sidplay=$HAVE_CXX
MPD_AUTO_PRE(sidplay, [sidplay decoder plugin], [No C++ compiler found])
@@ -1176,6 +1170,14 @@ fi
AM_CONDITIONAL(ENABLE_WILDMIDI, test x$enable_wildmidi = xyes)
+dnl ------------------------ Post Decoder Plugins Tests -----------------------
+
+AM_CONDITIONAL(HAVE_OGG_COMMON,
+ test x$enable_vorbis = xyes || test x$enable_oggflac = xyes || test x$enable_flac = xyes)
+
+AM_CONDITIONAL(HAVE_FLAC_COMMON,
+ test x$enable_flac = xyes || test x$enable_oggflac = xyes)
+
dnl
dnl Encoder API and shout/httpd output plugin
dnl