aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 03:58:24 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:35:30 -0700
commit3bb03db09714eb0eac37cc967396e5cc62b823f3 (patch)
treeed9dd8107abd5176d8295db2e8f1c66d7a6cbbd7 /configure.ac
parentee88b8f8c47dec9bba39637f86b93f5eae01f42a (diff)
downloadmpd-3bb03db09714eb0eac37cc967396e5cc62b823f3.tar.gz
mpd-3bb03db09714eb0eac37cc967396e5cc62b823f3.tar.xz
mpd-3bb03db09714eb0eac37cc967396e5cc62b823f3.zip
configure.ac: Move ffmpeg to Decoder Plugins, add header.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac63
1 files changed, 29 insertions, 34 deletions
diff --git a/configure.ac b/configure.ac
index 5795fc5b1..384882552 100644
--- a/configure.ac
+++ b/configure.ac
@@ -850,6 +850,35 @@ AM_PATH_FAAD()
AM_CONDITIONAL(HAVE_FAAD, test x$enable_aac = xyes)
AM_CONDITIONAL(HAVE_MP4, test x$enable_mp4 = xyes)
+dnl ---------------------------------- ffmpeg ---------------------------------
+MPD_AUTO_PKG(ffmpeg, FFMPEG, [libavformat libavcodec libavutil],
+ [ffmpeg decoder library], [libavformat+libavcodec+libavutil not found])
+
+if test x$enable_ffmpeg = xyes; then
+ old_LIBS=$LIBS
+ LIBS="$LIBS $FFMPEG_LIBS"
+ AC_CHECK_LIB(avcodec, avcodec_decode_audio2,,
+ enable_ffmpeg=no)
+ LIBS=$old_LIBS
+fi
+
+if test x$enable_ffmpeg = xyes; then
+ # prior to ffmpeg svn12865, you had to specify include files
+ # without path prefix
+ old_CPPCFLAGS=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS $FFMPEG_CFLAGS"
+ AC_CHECK_HEADER(libavcodec/avcodec.h,,
+ AC_DEFINE(OLD_FFMPEG_INCLUDES, 1,
+ [Define if avcodec.h instead of libavcodec/avcodec.h should be included]))
+ CPPCFLAGS=$old_CPPFLAGS
+fi
+
+if test x$enable_ffmpeg = xyes; then
+ AC_DEFINE(HAVE_FFMPEG, 1, [Define for FFMPEG support])
+fi
+
+AM_CONDITIONAL(HAVE_FFMPEG, test x$enable_ffmpeg = xyes)
+
dnl ----------------------------------- FLAC ----------------------------------
if test x$enable_flac = xyes; then
PKG_CHECK_MODULES(FLAC, [flac >= 1.1],
@@ -1147,40 +1176,6 @@ fi
AM_CONDITIONAL(ENABLE_WILDMIDI, test x$enable_wildmidi = xyes)
-
-MPD_AUTO_PKG(ffmpeg, FFMPEG, [libavformat libavcodec libavutil],
- [ffmpeg decoder library], [libavformat+libavcodec+libavutil not found])
-
-if test x$enable_ffmpeg = xyes; then
- old_LIBS=$LIBS
- LIBS="$LIBS $FFMPEG_LIBS"
- AC_CHECK_LIB(avcodec, avcodec_decode_audio2,,
- enable_ffmpeg=no)
- LIBS=$old_LIBS
-fi
-
-if test x$enable_ffmpeg = xyes; then
- # prior to ffmpeg svn12865, you had to specify include files
- # without path prefix
- old_CPPCFLAGS=$CPPFLAGS
- CPPFLAGS="$CPPFLAGS $FFMPEG_CFLAGS"
- AC_CHECK_HEADER(libavcodec/avcodec.h,,
- AC_DEFINE(OLD_FFMPEG_INCLUDES, 1,
- [Define if avcodec.h instead of libavcodec/avcodec.h should be included]))
- CPPCFLAGS=$old_CPPFLAGS
-fi
-
-if test x$enable_ffmpeg = xyes; then
- AC_DEFINE(HAVE_FFMPEG, 1, [Define for FFMPEG support])
-fi
-
-AM_CONDITIONAL(HAVE_FFMPEG, test x$enable_ffmpeg = xyes)
-
-
-
-
-
-
dnl
dnl Encoder API and shout/httpd output plugin
dnl