aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2e1632e74..bc12d0900 100644
--- a/configure.ac
+++ b/configure.ac
@@ -756,6 +756,14 @@ if test x$enable_ffmpeg = xyes; then
fi
if test x$enable_ffmpeg = xyes; then
+ old_LIBS=$LIBS
+ LIBS="$LIBS $FFMPEG_LIBS"
+ AC_CHECK_LIB(avcodec, avcodec_decode_audio2,,
+ enable_ffmpeg=no)
+ LIBS=$old_LIBS
+fi
+
+if test x$enable_ffmpeg = xyes; then
# prior to ffmpeg svn12865, you had to specify include files
# without path prefix
old_CPPCFLAGS=$CPPFLAGS