aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-11-04 17:42:37 +0100
committerMax Kellermann <max@duempel.org>2008-11-04 17:42:37 +0100
commit104d5120c9754ffe9ca6fbd532d24abc98ef4155 (patch)
treecbf547aff0f1b159ab38e7deb0407401db59430b /configure.ac
parent85a7d1a1487dd29705b6df5175727d565350c784 (diff)
downloadmpd-104d5120c9754ffe9ca6fbd532d24abc98ef4155.tar.gz
mpd-104d5120c9754ffe9ca6fbd532d24abc98ef4155.tar.xz
mpd-104d5120c9754ffe9ca6fbd532d24abc98ef4155.zip
configure.ac: check for avcodec_decode_audio2()
Disable the ffmpeg decoder plugin if avcodec_decode_audio2() is not available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2e1632e74..bc12d0900 100644
--- a/configure.ac
+++ b/configure.ac
@@ -756,6 +756,14 @@ if test x$enable_ffmpeg = xyes; then
fi
if test x$enable_ffmpeg = xyes; then
+ old_LIBS=$LIBS
+ LIBS="$LIBS $FFMPEG_LIBS"
+ AC_CHECK_LIB(avcodec, avcodec_decode_audio2,,
+ enable_ffmpeg=no)
+ LIBS=$old_LIBS
+fi
+
+if test x$enable_ffmpeg = xyes; then
# prior to ffmpeg svn12865, you had to specify include files
# without path prefix
old_CPPCFLAGS=$CPPFLAGS