aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-22 17:18:03 +0100
committerMax Kellermann <max@duempel.org>2009-02-22 17:18:03 +0100
commitf7c685f1abaf8201d8bdc2b520b5529dfaf474dd (patch)
tree5b4b6594ab7ab9617a1811045f889e1a6e50bc4e /configure.ac
parent3a6619d62c19770211757916c55fa9436385ae20 (diff)
downloadmpd-f7c685f1abaf8201d8bdc2b520b5529dfaf474dd.tar.gz
mpd-f7c685f1abaf8201d8bdc2b520b5529dfaf474dd.tar.xz
mpd-f7c685f1abaf8201d8bdc2b520b5529dfaf474dd.zip
encoder: added lame mp3 encoder
This new LAME encoder plugin is based on the existing shout_mp3.c plugin.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aca891edc..572917cd2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -594,6 +594,10 @@ AM_CONDITIONAL(ENABLE_VORBIS_ENCODER, test x$enable_shout_ogg = xyes)
if test x$enable_shout_ogg = xyes; then
AC_DEFINE(ENABLE_VORBIS_ENCODER, 1, [Define to enable the vorbis encoder plugin]),
fi
+AM_CONDITIONAL(ENABLE_LAME_ENCODER, test x$enable_shout_mp3 = xyes)
+if test x$enable_shout_mp3 = xyes; then
+ AC_DEFINE(ENABLE_LAME_ENCODER, 1, [Define to enable the lame encoder plugin]),
+fi
if test x$enable_ao = xyes; then
PKG_CHECK_MODULES(AO, [ao],