aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-22 17:17:26 +0100
committerMax Kellermann <max@duempel.org>2009-02-22 17:17:26 +0100
commit3a6619d62c19770211757916c55fa9436385ae20 (patch)
tree40d4cf47628f79bcc5617293cff1fcce54bdba1e /configure.ac
parenta9dde676be62195aace54a1e3defefdc78a317f1 (diff)
downloadmpd-3a6619d62c19770211757916c55fa9436385ae20.tar.gz
mpd-3a6619d62c19770211757916c55fa9436385ae20.tar.xz
mpd-3a6619d62c19770211757916c55fa9436385ae20.zip
encoder: added vorbis encoder
This new vorbis encoder plugin is based on the existing shout_ogg.c plugin.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b8fefa06b..aca891edc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -590,6 +590,10 @@ AM_CONDITIONAL(HAVE_SHOUT_OGG, test x$enable_shout_ogg = xyes)
AM_CONDITIONAL(HAVE_SHOUT_MP3, test x$enable_shout_mp3 = xyes)
AM_CONDITIONAL(ENABLE_ENCODER, test x$enable_shout = xyes)
+AM_CONDITIONAL(ENABLE_VORBIS_ENCODER, test x$enable_shout_ogg = xyes)
+if test x$enable_shout_ogg = xyes; then
+ AC_DEFINE(ENABLE_VORBIS_ENCODER, 1, [Define to enable the vorbis encoder plugin]),
+fi
if test x$enable_ao = xyes; then
PKG_CHECK_MODULES(AO, [ao],