aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-04-13 20:47:28 +0200
committerMax Kellermann <max@duempel.org>2009-04-13 20:47:28 +0200
commite1f0c5347c2eb96adb997679d61e12f655d3fe28 (patch)
treeb602c720d28f058ceac93d972d02119799c9815d /configure.ac
parente216e01ab3db0d9bea179b043276401d38bfd957 (diff)
downloadmpd-e1f0c5347c2eb96adb997679d61e12f655d3fe28.tar.gz
mpd-e1f0c5347c2eb96adb997679d61e12f655d3fe28.tar.xz
mpd-e1f0c5347c2eb96adb997679d61e12f655d3fe28.zip
configure.ac: detect libiso9660 with pkg-config
Fail if the iso9660 plugin is enabled but not found.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index f7edd8145..da73fd4c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -338,11 +338,8 @@ AC_ARG_ENABLE(iso9660,
[enable iso9660 archive support (default: disabled)]),,
enable_iso9660=no)
-if test x$enable_iso9660 = xyes; then
- AC_CHECK_LIB(iso9660, iso9660_ifs_readdir,
- [MPD_LIBS="$MPD_LIBS -liso9660"],
- enable_iso9660=no)
-fi
+MPD_AUTO_PKG(iso9660, ISO9660, [libiso9660],
+ [libiso9660 archive library], [libiso9660 not found])
AM_CONDITIONAL(HAVE_ISO, test x$enable_iso9660 = xyes)
if test x$enable_iso9660 = xyes; then