aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-04-13 20:46:31 +0200
committerMax Kellermann <max@duempel.org>2009-04-13 20:46:31 +0200
commite216e01ab3db0d9bea179b043276401d38bfd957 (patch)
treef22ad6116f910e2737d48a7de7c50878372b0742 /configure.ac
parentc824013e94743feb05c45fa82c3e81cceda120fa (diff)
downloadmpd-e216e01ab3db0d9bea179b043276401d38bfd957.tar.gz
mpd-e216e01ab3db0d9bea179b043276401d38bfd957.tar.xz
mpd-e216e01ab3db0d9bea179b043276401d38bfd957.zip
configure.ac: detect libzzip with pkg-config
Fail if the zzip plugin is enabled but not found.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 67945b51b..f7edd8145 100644
--- a/configure.ac
+++ b/configure.ac
@@ -324,11 +324,8 @@ AC_ARG_ENABLE(zip,
[enable zip archive support (default: disabled)]),,
enable_zip=no)
-if test x$enable_zip = xyes; then
- AC_CHECK_LIB(zzip, zzip_dir_open,
- [MPD_LIBS="$MPD_LIBS -lzzip"],
- enable_zip=no)
-fi
+MPD_AUTO_PKG(zip, ZZIP, [zziplib],
+ [libzzip archive library], [libzzip not found])
AM_CONDITIONAL(HAVE_ZIP, test x$enable_zip = xyes)
if test x$enable_zip = xyes; then