aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-04-15 22:29:16 +0200
committerMax Kellermann <max@duempel.org>2009-04-15 22:29:16 +0200
commit9db7c13ef5b8f2e99eb92335205af377cc3acbbd (patch)
treece06121a2593ae684cb0c5fc4440f6170af413f6 /configure.ac
parentc13cecc0ae4a653d7d2a7913710ee253f9bb28b7 (diff)
downloadmpd-9db7c13ef5b8f2e99eb92335205af377cc3acbbd.tar.gz
mpd-9db7c13ef5b8f2e99eb92335205af377cc3acbbd.tar.xz
mpd-9db7c13ef5b8f2e99eb92335205af377cc3acbbd.zip
configure.ac: check for C++ detection failure
When no C++ compiler is found, let CXX fall back to $CC, and disable all features which require C++.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 907f8df77..1ff5a3600 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,6 +15,21 @@ dnl
AC_PROG_CC_C99
AC_PROG_CXX
+HAVE_CXX=yes
+if test x$CXX = xg++; then
+ # CXX=g++ probably means that autoconf hasn't found any C++
+ # compiler; to be sure, we check again
+ AC_PATH_PROG(CXX, $CXX, no)
+ if test x$CXX = xno; then
+ # no, we don't have C++ - the following hack is
+ # required because automake insists on using $(CXX)
+ # for linking the MPD binary
+ AC_MSG_NOTICE([Disabling C++ support])
+ CXX="$CC"
+ HAVE_CXX=no
+ fi
+fi
+
AC_PROG_INSTALL
AC_PROG_MAKE_SET
PKG_PROG_PKG_CONFIG
@@ -430,6 +445,9 @@ AC_ARG_ENABLE(modplug,
[enable modplug decoder plugin]),,
enable_modplug=auto)
+found_modplug=$HAVE_CXX
+MPD_AUTO_PRE(modplug, [modplug decoder plugin], [No C++ compiler found])
+
MPD_AUTO_PKG(modplug, MODPLUG, [libmodplug],
[modplug decoder plugin], [libmodplug not found])
AM_CONDITIONAL(HAVE_MODPLUG, test x$enable_modplug = xyes)
@@ -476,6 +494,9 @@ AC_ARG_ENABLE(sidplay,
[enable C64 SID support via libsidplay2]),,
enable_sidplay=auto)
+found_sidplay=$HAVE_CXX
+MPD_AUTO_PRE(sidplay, [sidplay decoder plugin], [No C++ compiler found])
+
if test x$enable_sidplay != xno; then
# we're not using pkg-config here
# because libsidplay2's .pc file requires libtool