aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-04-15 22:24:59 +0200
committerMax Kellermann <max@duempel.org>2009-04-15 22:24:59 +0200
commitc13cecc0ae4a653d7d2a7913710ee253f9bb28b7 (patch)
tree4c71c8ad2d5946e3cd24489dca3a4b9704c926e3 /configure.ac
parent6e6917ac4e05b563eb3673a052cc973456329880 (diff)
downloadmpd-c13cecc0ae4a653d7d2a7913710ee253f9bb28b7.tar.gz
mpd-c13cecc0ae4a653d7d2a7913710ee253f9bb28b7.tar.xz
mpd-c13cecc0ae4a653d7d2a7913710ee253f9bb28b7.zip
configure.ac: automatically detect the sidplay decoder
Set sidplay to "auto" by default, and enable it when it's found.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1b07a61d4..907f8df77 100644
--- a/configure.ac
+++ b/configure.ac
@@ -473,10 +473,10 @@ AC_ARG_WITH(tremor-includes,
AC_ARG_ENABLE(sidplay,
AS_HELP_STRING([--enable-sidplay],
- [enable C64 SID support via libsidplay2 (default: disable)]),,
- enable_sidplay=no)
+ [enable C64 SID support via libsidplay2]),,
+ enable_sidplay=auto)
-if test x$enable_sidplay = xyes; then
+if test x$enable_sidplay != xno; then
# we're not using pkg-config here
# because libsidplay2's .pc file requires libtool
AC_HAVE_LIBRARY(sidplay2, [found_sidplay=yes], [found_sidplay=no])