aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-10-15 20:40:04 +0200
committerMax Kellermann <max@duempel.org>2008-10-15 20:40:04 +0200
commit92513c3309b1cd01633e1f359eb03a679c884e0d (patch)
tree308801d1c8ac59377a54154c4ae1d9c2c9fd1080 /configure.ac
parent30cd3455812b5a839552d5a0f6fa87a99f09c46a (diff)
downloadmpd-92513c3309b1cd01633e1f359eb03a679c884e0d.tar.gz
mpd-92513c3309b1cd01633e1f359eb03a679c884e0d.tar.xz
mpd-92513c3309b1cd01633e1f359eb03a679c884e0d.zip
shout: check for vorbisenc library
The switch from ogg.m4 to pkg-config intentionally disabled libvorbisenc. Enable it when shout_ogg is used.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c92c9a441..e3018a087 100644
--- a/configure.ac
+++ b/configure.ac
@@ -208,7 +208,9 @@ if test x$enable_shout_ogg = xyes; then
enable_shout_ogg=no
fi
if test x$enable_shout_ogg = xyes; then
- AC_DEFINE(HAVE_SHOUT_OGG, 1, [Define to enable ogg streaming support])
+ PKG_CHECK_MODULES(VORBISENC, [vorbisenc],
+ AC_DEFINE(HAVE_SHOUT_OGG, 1, [Define to enable ogg streaming support]),
+ enable_shout_ogg=no)
fi
fi