aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-12-29 11:27:11 +0100
committerMax Kellermann <max@duempel.org>2008-12-29 11:27:11 +0100
commit702d6a641dceca87b13c029388b7f9ab06750245 (patch)
tree521a29d9c85903b2aca7c0d4997e3a0dcafbc06b /configure.ac
parentdfe235900fa8f38c5043e092dc8a538d110e4a02 (diff)
downloadmpd-702d6a641dceca87b13c029388b7f9ab06750245.tar.gz
mpd-702d6a641dceca87b13c029388b7f9ab06750245.tar.xz
mpd-702d6a641dceca87b13c029388b7f9ab06750245.zip
configure.ac: append archive libraries to $MPD_LIBS
All archive plugins used to overwrite $MPD_LIBS, ignoring the existing value. Make them append instead, keeping the old value.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 79e44ffe6..f9a666d41 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,7 +197,9 @@ AC_ARG_ENABLE(bzip2,
enable_bz2=no)
if test x$enable_bz2 = xyes; then
- AC_CHECK_LIB(bz2, BZ2_bzDecompressInit,[MPD_LIBS="-lbz2";],enable_bz2=no)
+ AC_CHECK_LIB(bz2, BZ2_bzDecompressInit,
+ [MPD_LIBS="$MPD_LIBS -lbz2"],
+ enable_bz2=no)
fi
AM_CONDITIONAL(HAVE_BZ2, test x$enable_bz2 = xyes)
@@ -213,7 +215,9 @@ AC_ARG_ENABLE(zip,
enable_zip=no)
if test x$enable_zip = xyes; then
- AC_CHECK_LIB(zzip, zzip_dir_open,[MPD_LIBS="-lzzip";],enable_zip=no)
+ AC_CHECK_LIB(zzip, zzip_dir_open,
+ [MPD_LIBS="$MPD_LIBS -lzzip"],
+ enable_zip=no)
fi
AM_CONDITIONAL(HAVE_ZIP, test x$enable_zip = xyes)
@@ -229,12 +233,13 @@ AC_ARG_ENABLE(iso9660,
enable_iso=no)
if test x$enable_iso = xyes; then
- AC_CHECK_LIB(iso9660, iso9660_ifs_readdir ,,enable_iso=no)
+ AC_CHECK_LIB(iso9660, iso9660_ifs_readdir,
+ [MPD_LIBS="$MPD_LIBS -liso9660"],
+ enable_iso=no)
fi
AM_CONDITIONAL(HAVE_ISO, test x$enable_iso = xyes)
if test x$enable_iso = xyes; then
- MPD_LIBS="$MPD_LIBS -liso9660"
AC_DEFINE(HAVE_ISO, 1, [Define to have iso archive support])
fi