aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-12-29 10:01:33 +0100
committerMax Kellermann <max@duempel.org>2008-12-29 10:01:33 +0100
commitdfe235900fa8f38c5043e092dc8a538d110e4a02 (patch)
treef762cad1de4503c447953acc758f5702271fcc28 /configure.ac
parent8a8fdfb0ad2ff401ec607cbd3a7f33df3f360678 (diff)
downloadmpd-dfe235900fa8f38c5043e092dc8a538d110e4a02.tar.gz
mpd-dfe235900fa8f38c5043e092dc8a538d110e4a02.tar.xz
mpd-dfe235900fa8f38c5043e092dc8a538d110e4a02.zip
configure.ac: check for archive libraries only if enabled
Don't bother to look for libbz2, libzzip and libiso9660 if the plugins are disabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8aaf52893..79e44ffe6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -196,7 +196,9 @@ AC_ARG_ENABLE(bzip2,
enable_bz2=$enableval,
enable_bz2=no)
-AC_CHECK_LIB(bz2, BZ2_bzDecompressInit,[MPD_LIBS="-lbz2";],enable_bz2=no)
+if test x$enable_bz2 = xyes; then
+ AC_CHECK_LIB(bz2, BZ2_bzDecompressInit,[MPD_LIBS="-lbz2";],enable_bz2=no)
+fi
AM_CONDITIONAL(HAVE_BZ2, test x$enable_bz2 = xyes)
if test x$enable_bz2 = xyes; then
@@ -210,7 +212,9 @@ AC_ARG_ENABLE(zip,
enable_zip=$enableval,
enable_zip=no)
-AC_CHECK_LIB(zzip, zzip_dir_open,[MPD_LIBS="-lzzip";],enable_zip=no)
+if test x$enable_zip = xyes; then
+ AC_CHECK_LIB(zzip, zzip_dir_open,[MPD_LIBS="-lzzip";],enable_zip=no)
+fi
AM_CONDITIONAL(HAVE_ZIP, test x$enable_zip = xyes)
if test x$enable_zip = xyes; then
@@ -224,7 +228,9 @@ AC_ARG_ENABLE(iso9660,
enable_iso=$enableval,
enable_iso=no)
-AC_CHECK_LIB(iso9660, iso9660_ifs_readdir ,,enable_iso=no)
+if test x$enable_iso = xyes; then
+ AC_CHECK_LIB(iso9660, iso9660_ifs_readdir ,,enable_iso=no)
+fi
AM_CONDITIONAL(HAVE_ISO, test x$enable_iso = xyes)
if test x$enable_iso = xyes; then