aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-09-16 07:31:06 +0200
committerMax Kellermann <max@duempel.org>2011-09-16 07:41:41 +0200
commit443e96381a0e24d9c22578ba6f7fb96de1814994 (patch)
tree54fbf24b6ee23afd86443ab79a9b64271ff8d3a5 /configure.ac
parent1cbba4fc592654dc3a2a1fe337ed699d6a102b09 (diff)
downloadmpd-443e96381a0e24d9c22578ba6f7fb96de1814994.tar.gz
mpd-443e96381a0e24d9c22578ba6f7fb96de1814994.tar.xz
mpd-443e96381a0e24d9c22578ba6f7fb96de1814994.zip
configure.ac: disable assertions in the non-debugging build
Add -DNDEBUG to AM_CPPFLAGS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1c0a38ce1..9a9576271 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1451,10 +1451,9 @@ dnl CFLAGS
dnl ---------------------------------------------------------------------------
dnl ---------------------------------- debug ----------------------------------
-#if test "x$enable_debug" = xno; then
- # don't set NDEBUG for now, until MPD is stable
- #AM_CFLAGS="$AM_CFLAGS -DNDEBUG"
-#fi
+if test "x$enable_debug" = xno; then
+ AM_CPPFLAGS="$AM_CPPFLAGS -DNDEBUG"
+fi
dnl ----------------------------------- GCC -----------------------------------
if test x$GCC = xyes