aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-10-17 21:13:23 +0200
committerMax Kellermann <max@duempel.org>2008-10-17 21:13:23 +0200
commit25b5d90e448146b6efaf4926680e35aee4a0af6c (patch)
tree6567bb91758598aa4214bd1939c78487806456a9 /configure.ac
parent4984639b7255d72e272f278c95adb1a2cf71b61c (diff)
downloadmpd-25b5d90e448146b6efaf4926680e35aee4a0af6c.tar.gz
mpd-25b5d90e448146b6efaf4926680e35aee4a0af6c.tar.xz
mpd-25b5d90e448146b6efaf4926680e35aee4a0af6c.zip
Makefile.am: don't compile disabled sources
If a feature is disabled, don't compile the source file at all, disable it completely in Makefile.am instead.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ce50de896..5ff6b4071 100644
--- a/configure.ac
+++ b/configure.ac
@@ -412,6 +412,8 @@ if test x$enable_id3 = xyes; then
enable_id3=no)
fi
+AM_CONDITIONAL(HAVE_ID3TAG, test x$enable_id3 = xyes)
+
if test x$enable_mp3 = xyes; then
PKG_CHECK_MODULES([MAD], [mad],
AC_DEFINE(HAVE_MAD, 1, [Define to use libmad]),
@@ -694,6 +696,8 @@ if test x$with_zeroconf != xno; then
fi
fi
+AM_CONDITIONAL(HAVE_ZEROCONF, test x$with_zeroconf = xyes)
+
dnl
dnl build options