aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-03-21 09:01:56 +0100
committerMax Kellermann <max@duempel.org>2012-03-21 09:01:56 +0100
commit238c3adad1724054b454f76857307e368e519585 (patch)
tree37c079eb8340211c9830fc2683d74899456a9e9f /Makefile.am
parentc1d0a8b5ce93c4b70b00b14f2015fb6a57681dbe (diff)
downloadmpd-238c3adad1724054b454f76857307e368e519585.tar.gz
mpd-238c3adad1724054b454f76857307e368e519585.tar.xz
mpd-238c3adad1724054b454f76857307e368e519585.zip
decoder/dsdiff: reverse bits to most significant bit first
Allow to remove this complexity from the MPD core.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d7f7f2314..9936165c7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1046,6 +1046,7 @@ test_dump_playlist_LDADD = \
$(GLIB_LIBS)
test_dump_playlist_SOURCES = test/dump_playlist.c \
$(DECODER_SRC) \
+ src/util/bit_reverse.c \
src/io_thread.c src/io_thread.h \
src/conf.c src/tokenizer.c src/utils.c src/string_util.c\
src/uri.c \
@@ -1072,6 +1073,7 @@ test_run_decoder_LDADD = \
$(GLIB_LIBS)
test_run_decoder_SOURCES = test/run_decoder.c \
test/stdbin.h \
+ src/util/bit_reverse.c \
src/io_thread.c src/io_thread.h \
src/conf.c src/tokenizer.c src/utils.c src/string_util.c src/log.c \
src/tag.c src/tag_pool.c src/tag_handler.c \
@@ -1094,6 +1096,7 @@ test_read_tags_LDADD = \
$(TAG_LIBS) \
$(GLIB_LIBS)
test_read_tags_SOURCES = test/read_tags.c \
+ src/util/bit_reverse.c \
src/io_thread.c src/io_thread.h \
src/conf.c src/tokenizer.c src/utils.c src/string_util.c src/log.c \
src/tag.c src/tag_pool.c src/tag_handler.c \