aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-03-21 08:44:43 +0100
committerMax Kellermann <max@duempel.org>2012-03-21 08:44:43 +0100
commitc1d0a8b5ce93c4b70b00b14f2015fb6a57681dbe (patch)
treeacae564b851d4c799dd3bd635e25a18531770b94 /Makefile.am
parent08ce24ec3fb094f653b3f3421388edec02f1dced (diff)
downloadmpd-c1d0a8b5ce93c4b70b00b14f2015fb6a57681dbe.tar.gz
mpd-c1d0a8b5ce93c4b70b00b14f2015fb6a57681dbe.tar.xz
mpd-c1d0a8b5ce93c4b70b00b14f2015fb6a57681dbe.zip
dsd2pcm: move the bit reversing code to a generic library
Instead of doing run-time initialisation, use a constant lookup table.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c7b110354..d7f7f2314 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -227,6 +227,7 @@ src_mpd_SOURCES = \
$(MIXER_API_SRC) \
src/util/list.h \
src/util/list_sort.c src/util/list_sort.h \
+ src/util/bit_reverse.c src/util/bit_reverse.h \
src/glib_socket.h \
src/notify.c \
src/audio_config.c src/audio_config.h \
@@ -1174,6 +1175,7 @@ test_run_normalize_LDADD = \
$(GLIB_LIBS)
test_run_convert_SOURCES = test/run_convert.c \
+ src/util/bit_reverse.c \
src/dsd2pcm/dsd2pcm.c \
src/fifo_buffer.c \
src/audio_format.c \
@@ -1272,6 +1274,7 @@ if HAVE_CXX
noinst_PROGRAMS += src/dsd2pcm/dsd2pcm
src_dsd2pcm_dsd2pcm_SOURCES = \
+ src/util/bit_reverse.c \
src/dsd2pcm/dsd2pcm.c src/dsd2pcm/dsd2pcm.h \
src/dsd2pcm/noiseshape.c src/dsd2pcm/noiseshape.h \
src/dsd2pcm/main.cpp