aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 21 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index a61048f7..4974414e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,23 +175,31 @@ PKG_HAVE([freetype], [freetype2], yes)
# find sqlite3
PKG_HAVE([sqlite3], [sqlite3], yes)
-# find lua 5.2 or 5.11
+# find lua 5.3, 5.2 or 5.11
# (K)Ubuntu uses lua5.2.pc and lua5.1.pc,
# Mac OS X and other linux distributions use lua.pc
-PKG_HAVE([lua], [lua5.2], check)
-lua_lib_name="lua5.2"
+# Archlinux aur package for 5.3 use lua5.3.pc in order
+# to make it work alongside the 5.2 version.
+PKG_HAVE([lua], [lua5.3], check)
+lua_lib_name="lua5.3"
if [[ x$lua_HAVE = xyes ]]; then
- PKG_VERSION([lua], [lua5.2])
+ PKG_VERSION([lua], [lua5.3])
else
- PKG_HAVE([lua], [lua5.1], check)
- lua_lib_name="lua5.1"
- if [[ x$lua_HAVE = xyes ]]; then
- PKG_VERSION([lua], [lua5.1])
- else
- PKG_HAVE([lua], [lua >= 5.1], yes)
- lua_lib_name="lua"
- PKG_VERSION([lua], [lua])
- fi
+ PKG_HAVE([lua], [lua5.2], check)
+ lua_lib_name="lua5.2"
+ if [[ x$lua_HAVE = xyes ]]; then
+ PKG_VERSION([lua], [lua5.2])
+ else
+ PKG_HAVE([lua], [lua5.1], check)
+ lua_lib_name="lua5.1"
+ if [[ x$lua_HAVE = xyes ]]; then
+ PKG_VERSION([lua], [lua5.1])
+ else
+ PKG_HAVE([lua], [lua >= 5.1], yes)
+ lua_lib_name="lua"
+ PKG_VERSION([lua], [lua])
+ fi
+ fi
fi
AC_SUBST(lua_lib_name)