aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorbrian-ch <brian-ch@b956fd51-792f-4845-bead-9b4dfca2ff2c>2015-04-03 20:42:27 +0000
committerbrian-ch <brian-ch@b956fd51-792f-4845-bead-9b4dfca2ff2c>2015-04-03 20:42:27 +0000
commitf80199e9dfde699a8c6c3de5e182f64755805efd (patch)
treec8a0030f681840bde74a2144ccfa6311c229de9e /configure.ac
parentd3fab250e5da9a9d894d5e4d0c78d3d16b86a8f4 (diff)
downloadusdx-f80199e9dfde699a8c6c3de5e182f64755805efd.tar.gz
usdx-f80199e9dfde699a8c6c3de5e182f64755805efd.tar.xz
usdx-f80199e9dfde699a8c6c3de5e182f64755805efd.zip
Update configure to detect lua5.3 and ffmpeg 2.6
git-svn-id: svn://svn.code.sf.net/p/ultrastardx/svn/trunk@3113 b956fd51-792f-4845-bead-9b4dfca2ff2c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 21 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index a61048f7..4974414e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,23 +175,31 @@ PKG_HAVE([freetype], [freetype2], yes)
# find sqlite3
PKG_HAVE([sqlite3], [sqlite3], yes)
-# find lua 5.2 or 5.11
+# find lua 5.3, 5.2 or 5.11
# (K)Ubuntu uses lua5.2.pc and lua5.1.pc,
# Mac OS X and other linux distributions use lua.pc
-PKG_HAVE([lua], [lua5.2], check)
-lua_lib_name="lua5.2"
+# Archlinux aur package for 5.3 use lua5.3.pc in order
+# to make it work alongside the 5.2 version.
+PKG_HAVE([lua], [lua5.3], check)
+lua_lib_name="lua5.3"
if [[ x$lua_HAVE = xyes ]]; then
- PKG_VERSION([lua], [lua5.2])
+ PKG_VERSION([lua], [lua5.3])
else
- PKG_HAVE([lua], [lua5.1], check)
- lua_lib_name="lua5.1"
- if [[ x$lua_HAVE = xyes ]]; then
- PKG_VERSION([lua], [lua5.1])
- else
- PKG_HAVE([lua], [lua >= 5.1], yes)
- lua_lib_name="lua"
- PKG_VERSION([lua], [lua])
- fi
+ PKG_HAVE([lua], [lua5.2], check)
+ lua_lib_name="lua5.2"
+ if [[ x$lua_HAVE = xyes ]]; then
+ PKG_VERSION([lua], [lua5.2])
+ else
+ PKG_HAVE([lua], [lua5.1], check)
+ lua_lib_name="lua5.1"
+ if [[ x$lua_HAVE = xyes ]]; then
+ PKG_VERSION([lua], [lua5.1])
+ else
+ PKG_HAVE([lua], [lua >= 5.1], yes)
+ lua_lib_name="lua"
+ PKG_VERSION([lua], [lua])
+ fi
+ fi
fi
AC_SUBST(lua_lib_name)