aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 36b4e4ab..99f2fb3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -154,8 +154,16 @@ fi
# check for libraries
# -----------------------------------------
-# libpng
-PKG_HAVE([libpng], [libpng12], yes)
+# find libpng
+# pkgconfig name for 1.2 is "libpng12", for 1.4 "libpng"
+PKG_HAVE([libpng], [libpng12], no)
+if [[ x$libpng_HAVE = xyes ]]; then
+ PKG_VERSION([libpng], [libpng12])
+else
+ # check for the generic .pc file
+ PKG_HAVE([libpng], [libpng >= 1.2], yes)
+ PKG_VERSION([libpng], [libpng >= 1.2])
+fi
# find sdl
PKG_HAVE([sdl], [sdl], yes)