aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortobigun <tobigun@b956fd51-792f-4845-bead-9b4dfca2ff2c>2010-06-17 16:38:18 +0000
committertobigun <tobigun@b956fd51-792f-4845-bead-9b4dfca2ff2c>2010-06-17 16:38:18 +0000
commit7e517498f282e58c2d26f9ffd7c227da9cc622fe (patch)
tree7aa97eecd908d7c5074e9f551f908c7536116586 /configure.ac
parent9049c5461f21fd12418f63824b23e8cfdacc6edc (diff)
downloadusdx-7e517498f282e58c2d26f9ffd7c227da9cc622fe.tar.gz
usdx-7e517498f282e58c2d26f9ffd7c227da9cc622fe.tar.xz
usdx-7e517498f282e58c2d26f9ffd7c227da9cc622fe.zip
update configure to find libpng 1.4
git-svn-id: svn://svn.code.sf.net/p/ultrastardx/svn/trunk@2539 b956fd51-792f-4845-bead-9b4dfca2ff2c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 36b4e4ab..99f2fb3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -154,8 +154,16 @@ fi
# check for libraries
# -----------------------------------------
-# libpng
-PKG_HAVE([libpng], [libpng12], yes)
+# find libpng
+# pkgconfig name for 1.2 is "libpng12", for 1.4 "libpng"
+PKG_HAVE([libpng], [libpng12], no)
+if [[ x$libpng_HAVE = xyes ]]; then
+ PKG_VERSION([libpng], [libpng12])
+else
+ # check for the generic .pc file
+ PKG_HAVE([libpng], [libpng >= 1.2], yes)
+ PKG_VERSION([libpng], [libpng >= 1.2])
+fi
# find sdl
PKG_HAVE([sdl], [sdl], yes)