aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 12 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 72adc3bd1..51fb3b100 100644
--- a/configure.ac
+++ b/configure.ac
@@ -393,21 +393,6 @@ AC_ARG_WITH(tremor-includes,
[directory where Tremor header files are installed (optional)]),,
tremor_includes="")
-
-
-
-
-AC_CHECK_FUNCS(inotify_init inotify_init1)
-
-if test x$ac_cv_func_inotify_init = xno; then
- enable_inotify=no
-fi
-
-if test x$enable_inotify = xyes; then
- AC_DEFINE([ENABLE_INOTIFY], 1, [Define to enable inotify support])
-fi
-AM_CONDITIONAL(ENABLE_INOTIFY, test x$enable_inotify = xyes)
-
dnl ---------------------------------------------------------------------------
dnl Mandatory Libraries
dnl ---------------------------------------------------------------------------
@@ -465,9 +450,20 @@ if test x$enable_largefile != xno; then
fi
dnl ---------------------------------------------------------------------------
-dnl Optional Libraries
+dnl Miscellaneous Libraries
dnl ---------------------------------------------------------------------------
+AC_CHECK_FUNCS(inotify_init inotify_init1)
+
+if test x$ac_cv_func_inotify_init = xno; then
+ enable_inotify=no
+fi
+
+if test x$enable_inotify = xyes; then
+ AC_DEFINE([ENABLE_INOTIFY], 1, [Define to enable inotify support])
+fi
+AM_CONDITIONAL(ENABLE_INOTIFY, test x$enable_inotify = xyes)
+
if test x$enable_libwrap != xno; then
AC_CHECK_LIBWRAP(found_libwrap=yes, found_libwrap=no)
MPD_AUTO_RESULT(libwrap, libwrap, [libwrap not found])