aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-16 19:47:23 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:10:13 -0700
commita9ff134e9f8c3d0b0e92654d959d9a2f6ffc5fae (patch)
treede68e1715b64447505f1c959cd435b4cc42e0c66 /configure.ac
parent11fbb1c80778372a3df37fa1c6385a2eff58d8af (diff)
downloadmpd-a9ff134e9f8c3d0b0e92654d959d9a2f6ffc5fae.tar.gz
mpd-a9ff134e9f8c3d0b0e92654d959d9a2f6ffc5fae.tar.xz
mpd-a9ff134e9f8c3d0b0e92654d959d9a2f6ffc5fae.zip
configure.ac: Move inotify to "Miscellaneous Libraries".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 12 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 72adc3bd1..51fb3b100 100644
--- a/configure.ac
+++ b/configure.ac
@@ -393,21 +393,6 @@ AC_ARG_WITH(tremor-includes,
[directory where Tremor header files are installed (optional)]),,
tremor_includes="")
-
-
-
-
-AC_CHECK_FUNCS(inotify_init inotify_init1)
-
-if test x$ac_cv_func_inotify_init = xno; then
- enable_inotify=no
-fi
-
-if test x$enable_inotify = xyes; then
- AC_DEFINE([ENABLE_INOTIFY], 1, [Define to enable inotify support])
-fi
-AM_CONDITIONAL(ENABLE_INOTIFY, test x$enable_inotify = xyes)
-
dnl ---------------------------------------------------------------------------
dnl Mandatory Libraries
dnl ---------------------------------------------------------------------------
@@ -465,9 +450,20 @@ if test x$enable_largefile != xno; then
fi
dnl ---------------------------------------------------------------------------
-dnl Optional Libraries
+dnl Miscellaneous Libraries
dnl ---------------------------------------------------------------------------
+AC_CHECK_FUNCS(inotify_init inotify_init1)
+
+if test x$ac_cv_func_inotify_init = xno; then
+ enable_inotify=no
+fi
+
+if test x$enable_inotify = xyes; then
+ AC_DEFINE([ENABLE_INOTIFY], 1, [Define to enable inotify support])
+fi
+AM_CONDITIONAL(ENABLE_INOTIFY, test x$enable_inotify = xyes)
+
if test x$enable_libwrap != xno; then
AC_CHECK_LIBWRAP(found_libwrap=yes, found_libwrap=no)
MPD_AUTO_RESULT(libwrap, libwrap, [libwrap not found])