aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2ee505f96..b8179b31a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -529,6 +529,7 @@ libfs_a_CPPFLAGS = $(AM_CPPFLAGS) $(ZLIB_CFLAGS)
if HAVE_ZLIB
libfs_a_SOURCES += \
+ src/fs/io/GunzipReader.cxx src/fs/io/GunzipReader.hxx \
src/fs/io/GzipOutputStream.cxx src/fs/io/GzipOutputStream.hxx
FS_LIBS += $(ZLIB_LIBS)
endif
@@ -1617,12 +1618,21 @@ endif
if HAVE_ZLIB
-noinst_PROGRAMS += test/run_gzip
+noinst_PROGRAMS += test/run_gzip test/run_gunzip
+
test_run_gzip_LDADD = \
libutil.a \
$(FS_LIBS)
test_run_gzip_SOURCES = test/run_gzip.cxx
+test_run_gunzip_SOURCES = test/run_gunzip.cxx \
+ src/Log.cxx src/LogBackend.cxx
+test_run_gunzip_LDADD = \
+ $(GLIB_LIBS) \
+ libutil.a \
+ $(FS_LIBS) \
+ libsystem.a
+
endif
test_dump_text_file_LDADD = \