aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-08-07 17:14:58 +0200
committerMax Kellermann <max@duempel.org>2014-08-08 20:11:29 +0200
commita67a881715ca521347cc86631d770c9e6755c877 (patch)
tree762e32cadee52ea2a229010673e11d5b830b48b5 /Makefile.am
parent7a048f004dc1c7d35518e38c75861bc167ade945 (diff)
downloadmpd-a67a881715ca521347cc86631d770c9e6755c877.tar.gz
mpd-a67a881715ca521347cc86631d770c9e6755c877.tar.xz
mpd-a67a881715ca521347cc86631d770c9e6755c877.zip
input/GunzipInputStream: new class
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2ee505f96..b8179b31a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -529,6 +529,7 @@ libfs_a_CPPFLAGS = $(AM_CPPFLAGS) $(ZLIB_CFLAGS)
if HAVE_ZLIB
libfs_a_SOURCES += \
+ src/fs/io/GunzipReader.cxx src/fs/io/GunzipReader.hxx \
src/fs/io/GzipOutputStream.cxx src/fs/io/GzipOutputStream.hxx
FS_LIBS += $(ZLIB_LIBS)
endif
@@ -1617,12 +1618,21 @@ endif
if HAVE_ZLIB
-noinst_PROGRAMS += test/run_gzip
+noinst_PROGRAMS += test/run_gzip test/run_gunzip
+
test_run_gzip_LDADD = \
libutil.a \
$(FS_LIBS)
test_run_gzip_SOURCES = test/run_gzip.cxx
+test_run_gunzip_SOURCES = test/run_gunzip.cxx \
+ src/Log.cxx src/LogBackend.cxx
+test_run_gunzip_LDADD = \
+ $(GLIB_LIBS) \
+ libutil.a \
+ $(FS_LIBS) \
+ libsystem.a
+
endif
test_dump_text_file_LDADD = \