aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 14 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 147a15bf8..a96d69369 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -476,12 +476,6 @@ endif
libdecoder_plugins_a_SOURCES = \
src/decoder/PcmDecoderPlugin.cxx \
src/decoder/PcmDecoderPlugin.hxx \
- src/decoder/DsdiffDecoderPlugin.cxx \
- src/decoder/DsdiffDecoderPlugin.hxx \
- src/decoder/DsfDecoderPlugin.cxx \
- src/decoder/DsfDecoderPlugin.hxx \
- src/decoder/DsdLib.cxx \
- src/decoder/DsdLib.hxx \
src/DecoderBuffer.cxx src/DecoderBuffer.hxx \
src/DecoderPlugin.cxx \
src/DecoderList.cxx src/DecoderList.hxx
@@ -525,6 +519,16 @@ DECODER_LIBS = \
DECODER_SRC =
+if ENABLE_DSD
+libdecoder_plugins_a_SOURCES += \
+ src/decoder/DsdiffDecoderPlugin.cxx \
+ src/decoder/DsdiffDecoderPlugin.hxx \
+ src/decoder/DsfDecoderPlugin.cxx \
+ src/decoder/DsfDecoderPlugin.hxx \
+ src/decoder/DsdLib.cxx \
+ src/decoder/DsdLib.hxx
+endif
+
if HAVE_MAD
libdecoder_plugins_a_SOURCES += \
src/decoder/MadDecoderPlugin.cxx \
@@ -1559,6 +1563,8 @@ test_test_queue_priority_LDADD = \
libutil.a \
$(CPPUNIT_LIBS)
+if ENABLE_DSD
+
noinst_PROGRAMS += src/pcm/dsd2pcm/dsd2pcm
src_pcm_dsd2pcm_dsd2pcm_SOURCES = \
@@ -1571,6 +1577,8 @@ src_pcm_dsd2pcm_dsd2pcm_LDADD = libutil.a
endif
+endif
+
#
# Documentation