aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-09-26 09:00:58 +0200
committerMax Kellermann <max@duempel.org>2014-09-26 09:29:18 +0200
commit8bf46a665e4b4bd9d663351fbfb8ff47b59dfdd6 (patch)
treed0895464e3ffb420f0b0ab358023a38b1727a801 /Makefile.am
parentc4fca2aa614741f3d5bfef4eff039ae52c1a0a15 (diff)
downloadmpd-8bf46a665e4b4bd9d663351fbfb8ff47b59dfdd6.tar.gz
mpd-8bf46a665e4b4bd9d663351fbfb8ff47b59dfdd6.tar.xz
mpd-8bf46a665e4b4bd9d663351fbfb8ff47b59dfdd6.zip
configure.ac: add option to disable the DSD decoders
Allow building a smaller MPD binary for people who don't need DSD.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 14 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 147a15bf8..a96d69369 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -476,12 +476,6 @@ endif
libdecoder_plugins_a_SOURCES = \
src/decoder/PcmDecoderPlugin.cxx \
src/decoder/PcmDecoderPlugin.hxx \
- src/decoder/DsdiffDecoderPlugin.cxx \
- src/decoder/DsdiffDecoderPlugin.hxx \
- src/decoder/DsfDecoderPlugin.cxx \
- src/decoder/DsfDecoderPlugin.hxx \
- src/decoder/DsdLib.cxx \
- src/decoder/DsdLib.hxx \
src/DecoderBuffer.cxx src/DecoderBuffer.hxx \
src/DecoderPlugin.cxx \
src/DecoderList.cxx src/DecoderList.hxx
@@ -525,6 +519,16 @@ DECODER_LIBS = \
DECODER_SRC =
+if ENABLE_DSD
+libdecoder_plugins_a_SOURCES += \
+ src/decoder/DsdiffDecoderPlugin.cxx \
+ src/decoder/DsdiffDecoderPlugin.hxx \
+ src/decoder/DsfDecoderPlugin.cxx \
+ src/decoder/DsfDecoderPlugin.hxx \
+ src/decoder/DsdLib.cxx \
+ src/decoder/DsdLib.hxx
+endif
+
if HAVE_MAD
libdecoder_plugins_a_SOURCES += \
src/decoder/MadDecoderPlugin.cxx \
@@ -1559,6 +1563,8 @@ test_test_queue_priority_LDADD = \
libutil.a \
$(CPPUNIT_LIBS)
+if ENABLE_DSD
+
noinst_PROGRAMS += src/pcm/dsd2pcm/dsd2pcm
src_pcm_dsd2pcm_dsd2pcm_SOURCES = \
@@ -1571,6 +1577,8 @@ src_pcm_dsd2pcm_dsd2pcm_LDADD = libutil.a
endif
+endif
+
#
# Documentation