aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d5d9c0294..2b610a22f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -802,6 +802,14 @@ INPUT_LIBS = \
$(DESPOTIFY_LIBS) \
$(MMS_LIBS)
+if HAVE_ALSA
+libinput_a_SOURCES += \
+ src/input/AlsaInputPlugin.cxx \
+ src/input/AlsaInputPlugin.hxx
+INPUT_LIBS += $(ALSA_LIBS)
+endif
+
+
if ENABLE_CURL
libinput_a_SOURCES += \
src/input/CurlInputPlugin.cxx src/input/CurlInputPlugin.hxx \