aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSteven O'Brien <steven_obrien1@yahoo.co.uk>2013-12-15 16:52:21 +0000
committerMax Kellermann <max@duempel.org>2013-12-19 23:25:50 +0100
commit35f85ddd860a819dbdebed1124f572719b28ef0b (patch)
tree7ec692ec60f78df495bbe9ce09dfd5aa22f0c8c6 /Makefile.am
parente30fa7d15e71b9109f4f44c0b388e88b001031af (diff)
downloadmpd-35f85ddd860a819dbdebed1124f572719b28ef0b.tar.gz
mpd-35f85ddd860a819dbdebed1124f572719b28ef0b.tar.xz
mpd-35f85ddd860a819dbdebed1124f572719b28ef0b.zip
add draft ALSA input plugin
I've created an elementary input plugin that plays sound from the soundcard, so you can use MPD to listen to anything connected to the line-in jack, or to Video4Linux FM radio cards that send audio through the soundcard. There has been a small number of posts here in the past requesting line-in input, so here is a first, simplistic stab at it. The patch adds a new sheme, alsa://, which causes mpd to play data read directly from a souncdard. It defaults to hw:0,0, but you can pass any ALSA device name in the URI. So, using mpc for example: mpc add alsa:// mpc play will play from device hw:0,0. To use a diffferent device: mpc add alsa://hw:1,0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d5d9c0294..2b610a22f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -802,6 +802,14 @@ INPUT_LIBS = \
$(DESPOTIFY_LIBS) \
$(MMS_LIBS)
+if HAVE_ALSA
+libinput_a_SOURCES += \
+ src/input/AlsaInputPlugin.cxx \
+ src/input/AlsaInputPlugin.hxx
+INPUT_LIBS += $(ALSA_LIBS)
+endif
+
+
if ENABLE_CURL
libinput_a_SOURCES += \
src/input/CurlInputPlugin.cxx src/input/CurlInputPlugin.hxx \