aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-16 19:49:51 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:10:13 -0700
commite27dd7280fa9e8b170408ab7f07e30a54bc058d5 (patch)
tree034570f5102da4fd605b247af3a53cb8d337f01a /configure.ac
parenta9ff134e9f8c3d0b0e92654d959d9a2f6ffc5fae (diff)
downloadmpd-e27dd7280fa9e8b170408ab7f07e30a54bc058d5.tar.gz
mpd-e27dd7280fa9e8b170408ab7f07e30a54bc058d5.tar.xz
mpd-e27dd7280fa9e8b170408ab7f07e30a54bc058d5.zip
configure.ac: Move libid3tag to "Metadata Plugins"
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 13 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 51fb3b100..e5e2f872f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -488,6 +488,19 @@ fi
AM_CONDITIONAL(HAVE_CUE, test x$enable_cue = xyes)
+if test x$enable_id3 = xyes; then
+ PKG_CHECK_MODULES([ID3TAG], [id3tag],,
+ AC_CHECK_LIB(id3tag, id3_file_open,
+ [ID3TAG_LIBS="-lid3tag -lz" ID3TAG_CFLAGS=""],
+ enable_id3=no))
+fi
+
+if test x$enable_id3 = xyes; then
+ AC_DEFINE(HAVE_ID3TAG, 1, [Define to use id3tag])
+fi
+
+AM_CONDITIONAL(HAVE_ID3TAG, test x$enable_id3 = xyes)
+
dnl ---------------------------------------------------------------------------
dnl Autodiscovery
dnl ---------------------------------------------------------------------------
@@ -953,18 +966,7 @@ fi
AM_CONDITIONAL(HAVE_ALSA, test x$enable_alsa = xyes)
-if test x$enable_id3 = xyes; then
- PKG_CHECK_MODULES([ID3TAG], [id3tag],,
- AC_CHECK_LIB(id3tag, id3_file_open,
- [ID3TAG_LIBS="-lid3tag -lz" ID3TAG_CFLAGS=""],
- enable_id3=no))
-fi
-
-if test x$enable_id3 = xyes; then
- AC_DEFINE(HAVE_ID3TAG, 1, [Define to use id3tag])
-fi
-AM_CONDITIONAL(HAVE_ID3TAG, test x$enable_id3 = xyes)
if test x$enable_mpc = xyes; then
if test "x$mpcdec_libraries" != "x" ; then