aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-16 19:56:24 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:10:13 -0700
commitdd5fdbc540319f18dd4ece1f3345d9ffbf5c91e0 (patch)
tree9c14ce6d6e5cfdabeb8403d37c105fb1f56455b0 /configure.ac
parentb39855731c455720d59337a9a829ff61d5145dca (diff)
downloadmpd-dd5fdbc540319f18dd4ece1f3345d9ffbf5c91e0.tar.gz
mpd-dd5fdbc540319f18dd4ece1f3345d9ffbf5c91e0.tar.xz
mpd-dd5fdbc540319f18dd4ece1f3345d9ffbf5c91e0.zip
configure.ac: Move archive plugins around (alphabetize), add subheaders.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 18 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 050d8847d..2c6fca9c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -608,6 +608,22 @@ dnl ---------------------------------------------------------------------------
dnl Archive Plugins
dnl ---------------------------------------------------------------------------
+dnl --------------------------------- iso9660 ---------------------------------
+MPD_AUTO_PKG(iso9660, ISO9660, [libiso9660],
+ [libiso9660 archive library], [libiso9660 not found])
+
+AM_CONDITIONAL(HAVE_ISO9660, test x$enable_iso9660 = xyes)
+if test x$enable_iso9660 = xyes; then
+ AC_DEFINE(HAVE_ISO9660, 1, [Define to have ISO9660 archive support])
+
+ AC_PATH_PROG(MKISOFS, mkisofs, no)
+else
+ MKISOFS="no"
+fi
+
+AM_CONDITIONAL(ENABLE_ISO9660_TEST, test x$MKISOFS != xno)
+
+dnl ---------------------------------- libbz2 ---------------------------------
if test x$enable_bzip2 = xyes; then
AC_CHECK_LIB(bz2, BZ2_bzDecompressInit,
[MPD_LIBS="$MPD_LIBS -lbz2"],
@@ -625,6 +641,7 @@ fi
AM_CONDITIONAL(ENABLE_BZIP2_TEST, test x$BZIP2 != xno)
+dnl --------------------------------- libzzip ---------------------------------
MPD_AUTO_PKG(zzip, ZZIP, [zziplib >= 0.13],
[libzzip archive library], [libzzip not found])
@@ -639,21 +656,7 @@ fi
AM_CONDITIONAL(ENABLE_ZZIP_TEST, test x$ZIP != xno)
-MPD_AUTO_PKG(iso9660, ISO9660, [libiso9660],
- [libiso9660 archive library], [libiso9660 not found])
-
-AM_CONDITIONAL(HAVE_ISO9660, test x$enable_iso9660 = xyes)
-if test x$enable_iso9660 = xyes; then
- AC_DEFINE(HAVE_ISO9660, 1, [Define to have ISO9660 archive support])
-
- AC_PATH_PROG(MKISOFS, mkisofs, no)
-else
- MKISOFS="no"
-fi
-
-AM_CONDITIONAL(ENABLE_ISO9660_TEST, test x$MKISOFS != xno)
-
-dnl archive API
+dnl ------------------------------- Archive API -------------------------------
if
test x$enable_bzip2 = xyes ||
test x$enable_zzip = xyes ||