aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-16 19:52:45 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:10:13 -0700
commitb39855731c455720d59337a9a829ff61d5145dca (patch)
treef6053c86663ab41f029ae6a35fa8c1da6d8da25b /configure.ac
parente27dd7280fa9e8b170408ab7f07e30a54bc058d5 (diff)
downloadmpd-b39855731c455720d59337a9a829ff61d5145dca.tar.gz
mpd-b39855731c455720d59337a9a829ff61d5145dca.tar.xz
mpd-b39855731c455720d59337a9a829ff61d5145dca.zip
configure.ac: Add subheaders to Input/Sticker/Autodiscovery/Metadata and Misc.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e5e2f872f..050d8847d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -453,6 +453,7 @@ dnl ---------------------------------------------------------------------------
dnl Miscellaneous Libraries
dnl ---------------------------------------------------------------------------
+dnl --------------------------------- inotify ---------------------------------
AC_CHECK_FUNCS(inotify_init inotify_init1)
if test x$ac_cv_func_inotify_init = xno; then
@@ -464,6 +465,7 @@ if test x$enable_inotify = xyes; then
fi
AM_CONDITIONAL(ENABLE_INOTIFY, test x$enable_inotify = xyes)
+dnl --------------------------------- libwrap ---------------------------------
if test x$enable_libwrap != xno; then
AC_CHECK_LIBWRAP(found_libwrap=yes, found_libwrap=no)
MPD_AUTO_RESULT(libwrap, libwrap, [libwrap not found])
@@ -479,6 +481,7 @@ dnl ---------------------------------------------------------------------------
dnl Metadata Plugins
dnl ---------------------------------------------------------------------------
+dnl ---------------------------------- libcue ---------------------------------
MPD_AUTO_PKG(cue, CUE, [libcue],
[libcue parsing library], [libcue not found])
if test x$enable_cue = xyes; then
@@ -488,6 +491,7 @@ fi
AM_CONDITIONAL(HAVE_CUE, test x$enable_cue = xyes)
+dnl -------------------------------- libid3tag --------------------------------
if test x$enable_id3 = xyes; then
PKG_CHECK_MODULES([ID3TAG], [id3tag],,
AC_CHECK_LIB(id3tag, id3_file_open,
@@ -505,6 +509,8 @@ dnl ---------------------------------------------------------------------------
dnl Autodiscovery
dnl ---------------------------------------------------------------------------
+dnl --------------------------------- zeroconf --------------------------------
+
case $with_zeroconf in
no|avahi|bonjour)
;;
@@ -557,6 +563,8 @@ dnl ---------------------------------------------------------------------------
dnl Sticker Database
dnl ---------------------------------------------------------------------------
+dnl ---------------------------------- sqlite ---------------------------------
+
MPD_AUTO_PKG(sqlite, SQLITE, [sqlite3],
[SQLite database support], [sqlite not found])
if test x$enable_sqlite = xyes; then
@@ -569,6 +577,7 @@ dnl ---------------------------------------------------------------------------
dnl Input Plugins
dnl ---------------------------------------------------------------------------
+dnl ----------------------------------- CURL ----------------------------------
MPD_AUTO_PKG(curl, CURL, [libcurl],
[libcurl HTTP streaming], [libcurl not found])
if test x$enable_curl = xyes; then
@@ -576,6 +585,7 @@ if test x$enable_curl = xyes; then
fi
AM_CONDITIONAL(ENABLE_CURL, test x$enable_curl = xyes)
+dnl --------------------------------- Last.FM ---------------------------------
if test x$enable_lastfm = xyes; then
if test x$enable_curl != xyes; then
AC_MSG_ERROR([Cannot enable last.fm radio without curl])
@@ -585,6 +595,7 @@ if test x$enable_lastfm = xyes; then
fi
AM_CONDITIONAL(ENABLE_LASTFM, test x$enable_lastfm = xyes)
+dnl ---------------------------------- libmms ---------------------------------
MPD_AUTO_PKG(mms, MMS, [libmms >= 0.4],
[libmms mms:// protocol support], [libmms not found])
if test x$enable_mms = xyes; then