aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-10-28 22:25:58 +0100
committerMax Kellermann <max@duempel.org>2013-10-28 22:25:58 +0100
commitc37edfd3e934944283ccd943a2abb48adf7752d9 (patch)
treea9f72916c49bbfd2906cca3a7a8c20bb9bf67828 /configure.ac
parent4a99b1df4b35f4e20159790e899cf4ff2f9c4697 (diff)
downloadmpd-c37edfd3e934944283ccd943a2abb48adf7752d9.tar.gz
mpd-c37edfd3e934944283ccd943a2abb48adf7752d9.tar.xz
mpd-c37edfd3e934944283ccd943a2abb48adf7752d9.zip
configure.ac: disable the OS X output plugin by default
There hasn't been a maintainer for this plugin for years. It may even fail to build.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0aec84617..a16d80e87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -340,6 +340,11 @@ AC_ARG_ENABLE(oss,
[disable OSS support (default: enable)]),,
enable_oss=yes)
+AC_ARG_ENABLE(osx,
+ AS_HELP_STRING([--enable-osx],
+ [enable the OS X output plugin - unsupported! (default: disable)]),,
+ enable_osx=no)
+
AC_ARG_ENABLE(pipe-output,
AS_HELP_STRING([--enable-pipe-output],
[enable support for writing audio to a pipe (default: disable)]),,
@@ -1304,7 +1309,6 @@ fi
AM_CONDITIONAL(HAVE_OSS, test x$enable_oss = xyes)
dnl ----------------------------------- OSX -----------------------------------
-enable_osx=$host_is_darwin
if test x$enable_osx = xyes; then
AC_DEFINE(HAVE_OSX, 1, [Define for compiling OS X support])
LIBS="$LIBS -framework AudioUnit -framework CoreAudio -framework CoreServices"