aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-10-28 22:18:56 +0100
committerMax Kellermann <max@duempel.org>2013-10-28 22:18:56 +0100
commit4a99b1df4b35f4e20159790e899cf4ff2f9c4697 (patch)
treeb5b59b19daf1f4ec089f9563c4b778f9f6968aa7 /configure.ac
parent12e9b7eafacbbd20ccb6e8e73238c8dd351fa16f (diff)
downloadmpd-4a99b1df4b35f4e20159790e899cf4ff2f9c4697.tar.gz
mpd-4a99b1df4b35f4e20159790e899cf4ff2f9c4697.tar.xz
mpd-4a99b1df4b35f4e20159790e899cf4ff2f9c4697.zip
configure.ac: add variable host_is_darwin
Fixes the OpenAL detection which was broken because enable_osx was uesd which was set later.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 12 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index ae95fc560..0aec84617 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,8 @@ dnl OS Specific Defaults
dnl ---------------------------------------------------------------------------
AC_CANONICAL_HOST
+host_is_darwin=no
+
case "$host_os" in
mingw32* | windows*)
AC_CONFIG_FILES([
@@ -76,6 +78,10 @@ mingw32* | windows*)
LIBS="$LIBS -lws2_32"
HAVE_WINDOWS=1
;;
+
+darwin*)
+ host_is_darwin=yes
+ ;;
esac
AM_CONDITIONAL([HAVE_WINDOWS], [test x$HAVE_WINDOWS = x1])
@@ -1270,7 +1276,7 @@ AC_SUBST(OPENAL_CFLAGS,"")
AC_SUBST(OPENAL_LIBS,"")
if test x$enable_openal = xyes; then
- if test x$enable_osx = xyes; then
+ if test x$host_is_darwin = xyes; then
AC_CHECK_HEADERS([OpenAL/al.h OpenAL/alc.h], [], [enable_openal=no])
if test x$enable_openal = xyes; then
OPENAL_LIBS="-framework OpenAL"
@@ -1298,13 +1304,11 @@ fi
AM_CONDITIONAL(HAVE_OSS, test x$enable_oss = xyes)
dnl ----------------------------------- OSX -----------------------------------
-enable_osx=no
-case "$host_os" in
- darwin*)
- AC_DEFINE(HAVE_OSX, 1, [Define for compiling OS X support])
- LIBS="$LIBS -framework AudioUnit -framework CoreAudio -framework CoreServices"
- enable_osx=yes ;;
-esac
+enable_osx=$host_is_darwin
+if test x$enable_osx = xyes; then
+ AC_DEFINE(HAVE_OSX, 1, [Define for compiling OS X support])
+ LIBS="$LIBS -framework AudioUnit -framework CoreAudio -framework CoreServices"
+fi
AM_CONDITIONAL(HAVE_OSX, test x$enable_osx = xyes)