aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-10-16 23:46:11 +0200
committerMax Kellermann <max@duempel.org>2013-10-16 23:46:11 +0200
commitb0967cae691018347dd741003b54618faf085e3c (patch)
tree3a3fc8eda59b6bbe76340e7f9ded2391dca2826c /configure.ac
parent401a799a1b5de5d70a6b4c1d49235af0d5618f37 (diff)
downloadmpd-b0967cae691018347dd741003b54618faf085e3c.tar.gz
mpd-b0967cae691018347dd741003b54618faf085e3c.tar.xz
mpd-b0967cae691018347dd741003b54618faf085e3c.zip
configure.ac: don't leak -lsidutils -lmp3lame into
Make the third argument to AC_CHECK_LIB() non-empty to disable its default handler.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d411502e0..9e5f29df0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1047,7 +1047,7 @@ if test x$enable_sidplay != xno; then
[found_sidplay=yes], [found_sidplay=no])
if test x$found_sidplay = xyes; then
- AC_CHECK_LIB([sidutils],[main],[],[found_sidplay=no],[])
+ AC_CHECK_LIB([sidutils],[main],[:],[found_sidplay=no],[])
fi
MPD_AUTO_RESULT(sidplay, [sidplay decoder plugin],
@@ -1169,7 +1169,7 @@ dnl ------------------------------- LAME Encoder ------------------------------
if test x$enable_lame_encoder != xno; then
AC_CHECK_HEADERS(lame/lame.h,,
[AC_CHECK_HEADERS(lame.h,, using_lame=no)])
- AC_CHECK_LIB(mp3lame, lame_init,, using_lame=no)
+ AC_CHECK_LIB(mp3lame, lame_init, [:], using_lame=no)
if test x$using_lame != xno; then
AC_DEFINE(HAVE_LAME, 1, [Define to 1 if you have lame 3.98 or greater.])
LAME_LIBS="-lmp3lame -lm"