aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-10-16 21:55:00 +0200
committerMax Kellermann <max@duempel.org>2013-10-16 23:36:36 +0200
commit401a799a1b5de5d70a6b4c1d49235af0d5618f37 (patch)
tree503db86df98400dac818fa3bbfbe20e2055a1fa4 /configure.ac
parentba98518c69d0501e67ef707f0d718cc678851415 (diff)
downloadmpd-401a799a1b5de5d70a6b4c1d49235af0d5618f37.tar.gz
mpd-401a799a1b5de5d70a6b4c1d49235af0d5618f37.tar.xz
mpd-401a799a1b5de5d70a6b4c1d49235af0d5618f37.zip
test: use the CPPUNIT framework for unit tests
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0a98943cf..d411502e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1483,6 +1483,12 @@ AM_CONDITIONAL(ENABLE_DOCUMENTATION, test x$enable_documentation = xyes)
dnl ---------------------------------------------------------------------------
dnl test suite
dnl ---------------------------------------------------------------------------
+
+if test "x$enable_test" = xyes; then
+ PKG_CHECK_MODULES([CPPUNIT], [cppunit],,
+ [AC_MSG_ERROR([cppunit not found])])
+fi
+
AM_CONDITIONAL(ENABLE_TEST, test "x$enable_test" = xyes)
dnl ---------------------------------------------------------------------------