aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 03:34:06 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:10:15 -0700
commit97f80e04b05971c5d5f55b15dd7a9a98f88fa813 (patch)
tree98f324f9a899e60e89d0b172bb69844962405280 /configure.ac
parent944057c30b163e2a227355df14207d6abab70274 (diff)
downloadmpd-97f80e04b05971c5d5f55b15dd7a9a98f88fa813.tar.gz
mpd-97f80e04b05971c5d5f55b15dd7a9a98f88fa813.tar.xz
mpd-97f80e04b05971c5d5f55b15dd7a9a98f88fa813.zip
configure.ac: Move FluidSynth to Decoder Plugins, add header.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 9 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 3139d1090..b64f245c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1022,6 +1022,15 @@ AM_CONDITIONAL(HAVE_FLAC, test x$enable_flac = xyes)
enable_flac_encoder=$enable_flac
+dnl -------------------------------- FluidSynth -------------------------------
+if test x$enable_fluidsynth = xyes; then
+ PKG_CHECK_MODULES(FLUIDSYNTH, [fluidsynth],
+ AC_DEFINE(ENABLE_FLUIDSYNTH, 1, [Define for fluidsynth support]),
+ enable_fluidsynth=no)
+fi
+
+AM_CONDITIONAL(ENABLE_FLUIDSYNTH, test x$enable_fluidsynth = xyes)
+
enable_shout2="$enable_shout"
MPD_AUTO_PKG(shout, SHOUT, [shout],
@@ -1183,13 +1192,7 @@ fi
AM_CONDITIONAL(HAVE_FFMPEG, test x$enable_ffmpeg = xyes)
-if test x$enable_fluidsynth = xyes; then
- PKG_CHECK_MODULES(FLUIDSYNTH, [fluidsynth],
- AC_DEFINE(ENABLE_FLUIDSYNTH, 1, [Define for fluidsynth support]),
- enable_fluidsynth=no)
-fi
-AM_CONDITIONAL(ENABLE_FLUIDSYNTH, test x$enable_fluidsynth = xyes)
if test x$enable_wildmidi = xyes; then
oldcflags=$CFLAGS