aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 03:32:35 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:10:15 -0700
commit944057c30b163e2a227355df14207d6abab70274 (patch)
tree00d2dc9b68668322d5341a6d2ee5ae5a2df5dd39 /configure.ac
parent9c4d4bd6b04570afc3a02c83f6ba4aa0c7d31d57 (diff)
downloadmpd-944057c30b163e2a227355df14207d6abab70274.tar.gz
mpd-944057c30b163e2a227355df14207d6abab70274.tar.xz
mpd-944057c30b163e2a227355df14207d6abab70274.zip
configure.ac: Move FLAC to Decoder Plugins, add header.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 21 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index bd801cb71..3139d1090 100644
--- a/configure.ac
+++ b/configure.ac
@@ -999,7 +999,28 @@ AM_PATH_FAAD()
AM_CONDITIONAL(HAVE_FAAD, test x$enable_aac = xyes)
AM_CONDITIONAL(HAVE_MP4, test x$enable_mp4 = xyes)
+dnl ----------------------------------- FLAC ----------------------------------
+if test x$enable_flac = xyes; then
+ PKG_CHECK_MODULES(FLAC, [flac >= 1.1],
+ AC_DEFINE(HAVE_FLAC, 1, [Define for FLAC support]),
+ enable_flac=no)
+
+ oldcflags="$CFLAGS"
+ oldlibs="$LIBS"
+ CFLAGS="$CFLAGS $FLAC_CFLAGS"
+ LIBS="$LIBS $FLAC_LIBS"
+ if test x$enable_flac = xyes && test x$enable_oggflac = xyes; then
+ AC_CHECK_DECL(FLAC_API_SUPPORTS_OGG_FLAC,
+ [enable_oggflac=flac], [],
+ [#include <FLAC/export.h>])
+ fi
+ CFLAGS="$oldcflags"
+ LIBS="$oldlibs"
+fi
+AM_CONDITIONAL(HAVE_FLAC, test x$enable_flac = xyes)
+
+enable_flac_encoder=$enable_flac
enable_shout2="$enable_shout"
@@ -1113,27 +1134,7 @@ fi
AC_SUBST(TREMOR_CFLAGS)
AC_SUBST(TREMOR_LIBS)
-if test x$enable_flac = xyes; then
- PKG_CHECK_MODULES(FLAC, [flac >= 1.1],
- AC_DEFINE(HAVE_FLAC, 1, [Define for FLAC support]),
- enable_flac=no)
-
- oldcflags="$CFLAGS"
- oldlibs="$LIBS"
- CFLAGS="$CFLAGS $FLAC_CFLAGS"
- LIBS="$LIBS $FLAC_LIBS"
- if test x$enable_flac = xyes && test x$enable_oggflac = xyes; then
- AC_CHECK_DECL(FLAC_API_SUPPORTS_OGG_FLAC,
- [enable_oggflac=flac], [],
- [#include <FLAC/export.h>])
- fi
- CFLAGS="$oldcflags"
- LIBS="$oldlibs"
-fi
-AM_CONDITIONAL(HAVE_FLAC, test x$enable_flac = xyes)
-
-enable_flac_encoder=$enable_flac
if test x$enable_oggflac = xyes; then
oldmpdcflags="$MPD_CFLAGS"