aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-12-04 23:58:48 +0100
committerMax Kellermann <max@duempel.org>2014-12-05 00:21:48 +0100
commit5cbc319e964fb037793b51920b4ed164e8ed90af (patch)
tree4e1c98717312c28610cd219471f1c057dd470ab1 /configure.ac
parentd435dcdca46fd239cb4d25fa3c9db5c589a6a553 (diff)
downloadmpd-5cbc319e964fb037793b51920b4ed164e8ed90af.tar.gz
mpd-5cbc319e964fb037793b51920b4ed164e8ed90af.tar.xz
mpd-5cbc319e964fb037793b51920b4ed164e8ed90af.zip
configure.ac: require GLib 2.32 (if enabled)
Since version 2.32, g_thread_init() is deprecated and a no-op. Let's upgrade that (optional) dependency so we can remove all those g_thread_init() calls.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2291b9479..75e6526c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -522,7 +522,7 @@ AC_ARG_ENABLE(glib,
enable_glib=auto)
if test x$enable_glib != xno; then
- PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.28 gthread-2.0],
+ PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.32],
[found_glib=yes],
[found_glib=no])