aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-12-04 23:55:11 +0100
committerMax Kellermann <max@duempel.org>2014-12-05 00:21:48 +0100
commitd435dcdca46fd239cb4d25fa3c9db5c589a6a553 (patch)
tree8bba9656e20db5f21e24ee0cc3f4242fb59757e0 /configure.ac
parente5ab456df3a7c8fbb18763386aec1a3c2b4edf88 (diff)
downloadmpd-d435dcdca46fd239cb4d25fa3c9db5c589a6a553.tar.gz
mpd-d435dcdca46fd239cb4d25fa3c9db5c589a6a553.tar.xz
mpd-d435dcdca46fd239cb4d25fa3c9db5c589a6a553.zip
configure.ac: make GLib optional by default
Only very few (minor) features still depend on GLib.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 11 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 19af3c2dc..2291b9479 100644
--- a/configure.ac
+++ b/configure.ac
@@ -518,13 +518,18 @@ AM_CONDITIONAL(HAVE_ICU, test x$enable_icu = xyes)
AC_ARG_ENABLE(glib,
AS_HELP_STRING([--enable-glib],
- [enable GLib usage (default: enabled)]),,
- enable_glib=yes)
+ [enable GLib (default: auto)]),,
+ enable_glib=auto)
-if test x$enable_glib = xyes; then
- PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.28 gthread-2.0],,
- [AC_MSG_ERROR([GLib 2.28 is required])])
+if test x$enable_glib != xno; then
+ PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.28 gthread-2.0],
+ [found_glib=yes],
+ [found_glib=no])
+
+ MPD_AUTO_RESULT([glib], [Glib], [GLib not found])
+fi
+if test x$enable_glib = xyes; then
if test x$GCC = xyes; then
# suppress warnings in the GLib headers
GLIB_CFLAGS=`echo $GLIB_CFLAGS |sed -e 's,-I/,-isystem /,g'`
@@ -532,6 +537,7 @@ if test x$enable_glib = xyes; then
AC_DEFINE(HAVE_GLIB, 1, [Define if GLib is used])
fi
+
AM_CONDITIONAL(HAVE_GLIB, test x$enable_glib = xyes)
dnl ---------------------------------------------------------------------------