aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDenis Krjuchkov <alcohold@gmail.com>2010-10-08 23:55:14 +0600
committerDenis Krjuchkov <alcohold@gmail.com>2010-10-08 23:55:14 +0600
commit20004b7ee09db7de5a58ef50735b64309709a4c7 (patch)
tree9ae51c443fc7b851f6b1fe717e574d08adc2f837 /configure.ac
parent84e037631da0cf7e3d7099c566a181a2d506ed4c (diff)
downloadmpd-20004b7ee09db7de5a58ef50735b64309709a4c7.tar.gz
mpd-20004b7ee09db7de5a58ef50735b64309709a4c7.tar.xz
mpd-20004b7ee09db7de5a58ef50735b64309709a4c7.zip
win32_output: renamed win32 output plugin to winmm
Win32 has many audio APIs. New name is slightly more correct.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 255d036ec..c59845018 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1375,21 +1375,21 @@ esac
AM_CONDITIONAL(ENABLE_SOLARIS_OUTPUT, test x$enable_solaris_output = xyes)
-dnl --------------------------------- Solaris ---------------------------------
+dnl --------------------------------- WinMM ---------------------------------
case "$host_os" in
mingw32* | windows*)
- AC_DEFINE(ENABLE_WIN32_OUTPUT, 1, [Define to enable WIN32 wave support])
- enable_win32_output=yes
+ AC_DEFINE(ENABLE_WINMM_OUTPUT, 1, [Define to enable WinMM support])
+ enable_winmm_output=yes
MPD_LIBS="$MPD_LIBS -lwinmm"
;;
*)
- enable_win32_output=no
+ enable_winmm_output=no
;;
esac
-AM_CONDITIONAL(ENABLE_WIN32_OUTPUT, test x$enable_win32_output = xyes)
+AM_CONDITIONAL(ENABLE_WINMM_OUTPUT, test x$enable_winmm_output = xyes)
dnl --------------------- Post Audio Output Plugins Tests ---------------------
if
@@ -1407,7 +1407,7 @@ if
test x$enable_recorder_output = xno &&
test x$enable_shout = xno &&
test x$enable_solaris_output = xno &&
- test x$enable_win32_output = xno &&
+ test x$enable_winmm_output = xno &&
AC_MSG_ERROR([No Audio Output types configured!])
fi
@@ -1544,7 +1544,7 @@ results(mvp, [Media MVP])
results(shout, [SHOUTcast])
echo -ne '\n\t'
results(solaris, [Solaris])
-results(win32_output, [WIN32 wave])
+results(winmm_output, [WinMM])
if
test x$enable_shout = xyes ||