aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-16 19:58:00 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:10:13 -0700
commit191e520999c172a5316c3b54c2b32ab7ff32be36 (patch)
tree669f237cc27fb7448e476b5853469eeddc91f412 /configure.ac
parentdd5fdbc540319f18dd4ece1f3345d9ffbf5c91e0 (diff)
downloadmpd-191e520999c172a5316c3b54c2b32ab7ff32be36.tar.gz
mpd-191e520999c172a5316c3b54c2b32ab7ff32be36.tar.xz
mpd-191e520999c172a5316c3b54c2b32ab7ff32be36.zip
configure.ac: Move converter plugins up with other aux plugins.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 21 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 2c6fca9c3..b79e09ef8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -574,6 +574,27 @@ fi
AM_CONDITIONAL(ENABLE_SQLITE, test x$enable_sqlite = xyes)
dnl ---------------------------------------------------------------------------
+dnl Converter Plugins
+dnl ---------------------------------------------------------------------------
+
+dnl ------------------------------ libsamplerate ------------------------------
+MPD_AUTO_PKG(lsr, SAMPLERATE, [samplerate >= 0.0.15],
+ [libsamplerate resampling], [libsamplerate not found])
+if test x$enable_lsr = xyes; then
+ AC_DEFINE([HAVE_LIBSAMPLERATE], 1,
+ [Define to enable libsamplerate])
+fi
+
+if test x$enable_lsr = xyes; then
+ PKG_CHECK_MODULES([SAMPLERATE_013],
+ [samplerate >= 0.1.3],,
+ [AC_DEFINE([HAVE_LIBSAMPLERATE_NOINT], 1,
+ [libsamplerate doesn't provide src_int_to_float_array() (<0.1.3)])])
+fi
+
+AM_CONDITIONAL(HAVE_LIBSAMPLERATE, test x$enable_lsr = xyes)
+
+dnl ---------------------------------------------------------------------------
dnl Input Plugins
dnl ---------------------------------------------------------------------------
@@ -827,25 +848,7 @@ if test x$enable_wavpack = xyes; then
AC_DEFINE([HAVE_WAVPACK], 1, [Define to enable WavPack support])
fi
-dnl ---------------------------------------------------------------------------
-dnl Converter Plugins
-dnl ---------------------------------------------------------------------------
-MPD_AUTO_PKG(lsr, SAMPLERATE, [samplerate >= 0.0.15],
- [libsamplerate resampling], [libsamplerate not found])
-if test x$enable_lsr = xyes; then
- AC_DEFINE([HAVE_LIBSAMPLERATE], 1,
- [Define to enable libsamplerate])
-fi
-
-if test x$enable_lsr = xyes; then
- PKG_CHECK_MODULES([SAMPLERATE_013],
- [samplerate >= 0.1.3],,
- [AC_DEFINE([HAVE_LIBSAMPLERATE_NOINT], 1,
- [libsamplerate doesn't provide src_int_to_float_array() (<0.1.3)])])
-fi
-
-AM_CONDITIONAL(HAVE_LIBSAMPLERATE, test x$enable_lsr = xyes)
dnl ---------------------------------------------------------------------------
dnl Encoders for Streaming Audio Output Plugins