aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2011-11-13 14:19:38 -0800
committerAvuton Olrich <avuton@gmail.com>2011-11-14 05:09:18 -0800
commitef369c2e2b9334f05ad4fa78c44190bbdb9af3ba (patch)
tree4079ce0ca8ef4e2735b263c2f78e8ee514773a3e /Makefile.am
parent1e89ca09944e5889ef8ce258bd30ac76e3c8b7c0 (diff)
downloadmpd-ef369c2e2b9334f05ad4fa78c44190bbdb9af3ba.tar.gz
mpd-ef369c2e2b9334f05ad4fa78c44190bbdb9af3ba.tar.xz
mpd-ef369c2e2b9334f05ad4fa78c44190bbdb9af3ba.zip
Makefile.am: Add PULSE_LIBS for linking the mixer when compiling with pulse
Commit 3a3158 introduced a small bug where the pulseaudio mixer would not link with the main binary in some situations.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6b612529f..22856fe82 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,7 +33,7 @@ src_mpd_LDADD = \
$(OUTPUT_LIBS) \
$(FILTER_LIBS) \
$(ENCODER_LIBS) \
- libmixer_plugins.a \
+ $(MIXER_LIBS) \
$(GLIB_LIBS)
mpd_headers = \
@@ -741,6 +741,10 @@ OUTPUT_API_SRC = \
liboutput_plugins_a_SOURCES = \
src/output/null_output_plugin.c
+MIXER_LIBS = \
+ libmixer_plugins.a \
+ $(PULSE_LIBS)
+
MIXER_API_SRC = \
src/mixer_control.c \
src/mixer_type.c \